The keys on my Eclipse keyboard where getting a bit worn out. This is the third one I’ve had. I was in Best Buy and saw the K750 and thought I’d give it a try. It has much less key travel than the Eclipse but I liked the feel and the control key is the larger size  and easily used the way I’m used to using it – I hit it with the left side of my left hand. So I thought as well as a new keyboard why not try a new mouse also. I tried them each and got the M510. It’s got the forward/backward buttons and the tilting scroll wheel.

The Logitech stuff now comes with a unifying receiver – one receiver for up to 6 devices. That sounded like a good idea. The Eclipse was wired but being at the desk all the time the wire never bothered me. I plugged the receiver in and got pretty much nothing – not recognized, no driver, etc. etc.

Did a bunch of surfing and tried a few different things till I hit this on

“I will suggest you to try this steps to solve this problem. first you have to go to the ‘C:\Windows\System32\DriverStore\FileRepository\us b.inf_amd64_neutral_e2b28ecac19a29af’ and after that you have to copy usb.inf and usb.PNF file and then open C:\Windows\INF\ and paste here. Now after that you have to open device manager and then you have to right click on unknown device and select properties. After that you have to select deliver tab. Now click in update device and then select ‘Browse my computer for driver software’. Locate :\Windows\INF\. After that click on next. I hope this will fix your problem.”

Checked and I didn’t have a usb.inf file inf c:\windows\inf, so I thought it can’t hurt. I didn’t have a file named exactly “neutral_xxxx” like above, but I had two close. One had a 2011 date and one had a 2013 date. I took the usb.inf and pnf from the 2013 dated folder and put those in c:\windows\inf. Unplugged and plugged the receiver in and out – it did some searching and found it. Went into the unifying software and paired the keyboard and that’s what I”m using to write this. So I thought I’d post it here in case someone else has a similar problem.

Don’t know if it’s a Win7 64 bit problem or what or why I didn’t have a usb.inf and pnf files there. I would have thought with all the things I’ve had on this computer it would have shown up as a problem before but it didn’t.